How to install QGIS 2.16 on Ubuntu 16.04 Xenial Xerus

Quantum GIS (QGIS) is a rich features GIS Application that runs on Linux (and other systems). The new stable version of QGIS 2.16 is now available for Ubuntu users. This guide will show you how to install QGIS 2.16 on Ubuntu 16.04 and prepare Ubuntu to get future updates when available.

install qgis on Ubuntu 16.04QGIS is a free and open source GIS Application where you can create and manage your GIS projects. QGIS supports various file formats and database server such as PostGIS, SQL Server and many more.

Steps to install QGIS 2.16 on Ubuntu 16.04

  1. Add QGIS Repository to Ubuntu 16.04

Open Terminal and add the following lines to /etc/apt/sources.list

2. Update your system and install QGIS

Once completed, QGis can be accessed from Dash menu.

qgis-ubuntu

Ariel

3 Comments

  1. It did not work for me. I received this error message e it is not possible to install QGIS 2.16. Any suggestions?
    Erro GPG: http://qgis.org/ubuntugis xenial InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 073D307A618E5811
    W: The repository ‘http://qgis.org/ubuntugis xenial InRelease’ is not signed.
    N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    • sudo apt-get install qgis python-qgis qgis-plugin-grass
      Leyendo lista de paquetes… Hecho
      Creando árbol de dependencias
      Leyendo la información de estado… Hecho
      No se pudieron instalar algunos paquetes. Esto puede significar que
      usted pidió una situación imposible o, si está usando la distribución
      inestable, que algunos paquetes necesarios aún no se han creado o se
      han sacado de «Incoming».
      La siguiente información puede ayudar a resolver la situación:

      Los siguientes paquetes tienen dependencias incumplidas:
      python-qgis : Depende: libqgis-analysis2.18.3 pero no va a instalarse
      Depende: libqgis-server2.18.3 pero no va a instalarse
      Recomienda: liblwgeom-dev pero no va a instalarse
      qgis : Depende: gdal-abi-2-1-2
      Depende: libqgis-analysis2.18.3 pero no va a instalarse
      Depende: libqgis-app2.18.3 pero no va a instalarse
      qgis-plugin-grass : Depende: libqgis-app2.18.3 pero no va a instalarse
      E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

  2. Worked for me. Thanks heaps.
    Created a QGIS.list file in etc/apt/sources.list.d with the repository urls. Awesome

Leave a Reply

Your email address will not be published. Required fields are marked *