Powerful Video Recording App on Deepin 15.4 with Open Broadcaster Software 0.16.2

Open Broadcaster Software is a powerful and popular application among video content creators. OBS is multi platform and available as well on Linux OS. This tutorial is going to show you how to install OBS (Open Broadcaster Software) version 0.16.2 on Deepin Linux. Before we install, you may read the complete information about OBS from the official website.

Steps to install Open Broadcaster Software 0.16.2 on Deepin 15.4

Step 1. Add the Repository

Execute the following commands to add OBS repository to Deepin. If you have ffmpeg installed, you can skip this step.

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:kirillshkrogalev/ffmpeg-next
sudo apt-get update && sudo apt-get install ffmpeg

Step 2. Install OBS

Use these commands to install OBS

sudo add-apt-repository ppa:obsproject/obs-studio
sudo apt-get update && sudo apt-get install obs-studio

Those method was mentioned in OBS website but I got some errors when tried to install it on my Deepin 15.4. The following error was shown up on my Terminal:

dhani@dhani-deepin:~$ sudo add-apt-repository ppa:obsproject/obs-studio
Latest stable release of OBS Studio
More info: https://launchpad.net/~obsproject/+archive/ubuntu/obs-studio
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox ‘/tmp/tmpbjx1787g/pubring.gpg’ created
gpg: failed to start the dirmngr ‘/usr/bin/dirmngr’: No such file or directory
gpg: connecting dirmngr at ‘/tmp/tmpbjx1787g/S.dirmngr’ failed: No such file or directory
gpg: keyserver receive failed: No dirmngr
dhani@dhani-deepin:~$ sudo apt-get install obs-studio
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
obs-studio : Depends: libfontconfig1 (>= 2.11.94) but 2.11.1-1.1 is to be installed
E: Unable to correct problems, you have held broken packages.

After reboot, I re-execute the following command and it worked.

sudo apt-get install obs-studio

Finally I can run OBS Studio but I think this is not the same version as the official website. But anyway, I hope this problem will be fixed next time.

Ariel

Leave a Reply

Your email address will not be published. Required fields are marked *