Trying to configure iSCSI Server on OpenMediaVault 3.0.80–still not working!!!

I was failed to enable iSCSI Server plugin on OpenMediaVault 3.0.74. But now, I upgraded to OMV version 3.0.80 Erasmus. We will see if this new version has fixed this iSCSI plugin issue. So, basically I just want to show you how to configure the iSCSI server plugin on OMV 3.0.80 and see if it works. On my previous attempt, I could not run the iscsitarget service on OpenMediaVault.

Enable iSCSI plugin

Fist, we need to enable iSCSI target plugin. Go to Plugins page and find the openmediavault-iscsitarget plugin as follow.

iscsi plugin omv.png

At this point, if there is no error reported, we can continue to configuring the iSCSI Target.

Configure iSCSI Target

Go to Services | iSCSI Target to open the configuration. On the setting page, create a new discovery authentication if you want to enable this feature. Otherwise, go to Target tab. On the General tab, enter the identifier of the new target.

add target 1.png

Now add new user inside Authentication tab

add new user.png

Now we need to configure LUN. OMV only support Block IO transfer mode for the LUN. You will need a dedicated disk for this target. See my example below.

configure lun omv.png

Save the configuration and enable the iSCSI Service.

iscsi service.png

But, I still got the same error like this

omv error iscsi target.png

So basically, this issue has not been fixed yet. This really annoying

Failed to execute command ‘export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start iscsitarget 2>&1’ with exit code ‘1’: Job for iscsitarget.service failed. See ‘systemctl status iscsitarget.service’ and ‘journalctl -xn’ for details.

This is the status of the iscsitarget service

root@openmediavault:~# systemctl status iscsitarget
● iscsitarget.service – LSB: Starts and stops the iSCSI software target
Loaded: loaded (/etc/init.d/iscsitarget)
Active: failed (Result: exit-code) since Fri 2017-06-23 10:16:27 WITA; 2min 25s ago
Process: 29410 ExecStart=/etc/init.d/iscsitarget start (code=exited, status=1/FAILURE)

Jun 23 10:16:27 openmediavault systemd[1]: Starting LSB: Starts and stops the iSCSI software target…
Jun 23 10:16:27 openmediavault iscsitarget[29410]: Starting iSCSI enterprise target service:modprobe: FATAL: Mo…und.
Jun 23 10:16:27 openmediavault iscsitarget[29410]: failed!
Jun 23 10:16:27 openmediavault systemd[1]: iscsitarget.service: control process exited, code=exited status=1
Jun 23 10:16:27 openmediavault systemd[1]: Failed to start LSB: Starts and stops the iSCSI software target.
Jun 23 10:16:27 openmediavault systemd[1]: Unit iscsitarget.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

This error is due to the iscsitarget that won’t work on Kernel 4.0.0. And OpenMediaVault 3.0.80 uses Kernel 4.9.0 series. So far, there is no clue on how to get this things done.

Ariel

One Comment

Leave a Reply

Your email address will not be published. Required fields are marked *